Topic - srt file causing error

Reply to this topic

Topic Starter Zweihander - Posted on Friday, June 6 2008 11:15:44 PM
OS: 10.5.3
Mplayer: OS X version 1.0 rc1

This problem just cropped up randomly. It had been working before, but now seems to prevent me from playing two specific files.

I've got two video files that play normally, but when I put the .srt files into the same directory mplayer barfs out with an error. These subtitle files worked fine in the past, so I'm not sure what the problem is.

The subbing group for the srt files is the same, and I've even got more sub files from the same people that work just fine. I'm not sure what the problem is. Opening the files in VLC works fine, but VLC renders subtitles TERRIBLY and is the reason I use Mplayer in the first place.

Hereafter is the error log from

MOV: selected video stream (0) does not exists

MPlayer interrupted by signal 10 in module: read_subtitles_file
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
2008-06-06 19:12:45.067 MPlayer OSX[1585:20b] *** Assertion failure in -[NSTextFieldCell _objectValue:forString:errorDescription:], /SourceCache/AppKit/AppKit-949.33/AppKit.subproj/NSCell.m:1338
2008-06-06 19:12:45.068 MPlayer OSX[1585:20b] Exception raised during posting of notification. Ignored. exception: 'Invalid parameter not satisfying: aString != nil' invoked observer method: '*** -[PlayerController statusUpdate:]' observer: 0x16c420 notification name: 'MIStateUpdatedNotification'
2008-06-06 19:12:45.114 MPlayer OSX[1585:20b] Abnormal playback error. mplayer returned error code: 1

Any help would be awesome, and I'll be glad to post any more error messages or info if someone has an idea of what's going on.