Topic - m2ts subtitles and other problems

Reply to this topic

Topic Starter seth_keith - Posted on Wednesday, May 20 2009 06:34:25 AM
I am trying to find a subtitle solution for playing ripped blurays with mplayer-svn with vdpau. So far everything I have tried is unsuccessful, and i have found no definitive answers, please inform me about subtitles. I tried the following:

#1 - just play .m2ts file. No subtitles. I tried enabling/disabling, moving, delaying,etc. nothing

#2 - I extracted and converted a .sbr file. This will display with the -sub command but the subtitle text from far into the .sbr file starts playing instead of the beginning of the .sbr file

#3 - I extracted and converted to a .sub file and an .idx file. I tried to play these the -sub and also with -vosub, and neither worked at all.

What I am doning wrong here, I just want subtitles, any subtitles for my blurays.

I have some .mkv files with subtiles, and I cannot make these work either.

I tried making my own .mkv files, using tsmuexer and mkvtools, and even though the audio and video tracks I put into the .mkv are both independantly playable with mplayer, the resultant .mkv is unplayable giving me this:

Playing /mnt/rfs/video/Terminator.mkv.
[mkv] Track ID 1: video (V_MPEG2), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang und
[mkv] Track ID 3: subtitles (S_VOBSUB), -sid 0, -slang eng
[mkv] Track ID 4: subtitles (S_VOBSUB), -sid 1, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [mpg2] 1920x1080 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
dvdsublang...terminator english eng en
dvdsublang...terminator english eng en
dvdsublang...terminator english eng en
dvdsublang...terminator english eng en
dvdsublang...terminator english eng en
Forced video codec: ffmpeg12vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffmpeg12vdpau] vfm: ffmpeg (FFmpeg MPEG-1/2 (VDPAU))
Opening audio decoder: [liba52] AC3 decoding with liba52
No accelerated IMDCT transform found

MPlayer interrupted by signal 11 in module: init_audio_codec
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.

However, I can play .mkvs made by other people ( however without subtitles )

What am I donig wrong here please help me.