Topic - rtsp authorization broken in SVN-r29417-4.1.2

Reply to this topic

Topic Starter jackaroo - Posted on Tuesday, December 1 2009 01:25:42 AM

I'm using MPlayer SVN-r29417-4.1.2. on Centos 5.4 I am attempting to view an rtsp url of the form:

rtsp://admin:[email protected]/live/mjpeg

Where the username and password are set before the '@'. This url works fine for cvlc.

Doing a wireshark trace comparing cvlc and mplayer traffic I see that in both cases the video source responds with a 401 not authorized. cvlc then responds with an encrypted version of username and password and starts receiving the stream. mplayer does nothing further with the rtsp when the 401 arrives - actually it tries out variants of the url using http rather than rtsp.

I have tried to set the username and password using -user and -passwd arguments but get the same result.

I conclude the rtsp authentication code is broken in this version of mplayer. I have seen people using this form of rtsp url successfully in 2008 so I expect that this is a bug that has crept in.